Email sending issues
Incident Report for Bubble
Resolved
Queued emails have been sent. If you are still missing emails you believe should have been delivered, please re-send them.
Posted Jan 11, 2019 - 16:03 EST
Monitoring
Okay, emails should be going through again. The root cause of the issue was that the account we use to send emails from user apps that don't have their own SendGrid key got flagged by our email provider because of abusive emails sent by one of our apps (we have controls in place to prevent this but there was a technical issue and emails were able to get past them). The account is now un-flagged. We are confirming with our email provider when / whether emails sent that got blocked will be delivered.
Posted Jan 11, 2019 - 12:55 EST
Update
We've confirmed the problem and are working to resolve. We expect that emails that are not currently going through will send once the issue is fixed.
Posted Jan 11, 2019 - 11:42 EST
Identified
We are now seeing issues with email sends again. We are trying to get in touch with our email provider to figure out what is going on. Meanwhile, users on a custom domain can add their own Sendgrid key on the Settings -> Domain / email tab, which should resolve the problems for your app.
Posted Jan 11, 2019 - 11:05 EST
Monitoring
We are still monitoring to see if emails that were not delivered will be sent out, and will update accordingly. We have confirmed that new emails are sending normally. If your app is having problems with email sends, search your server logs for "Sending email failed" to see if there is a specific error.
Posted Jan 10, 2019 - 15:12 EST
Identified
New emails are now sending normally. We're investigating if we can make previously-sent emails go out
Posted Jan 10, 2019 - 12:38 EST
Investigating
Currently, many emails sent by Bubble apps are being queued. We're investigating why, and expect that the emails will be successfully sent once the issue is resolved. This does not affect apps using their own Sendgrid key.
Posted Jan 10, 2019 - 10:50 EST
This incident affected: Bubble Core (Main Bubble Environment).